Intermittent Email Delivery Service Issues
Incident Report for Luminello
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 07:15 PST
Update
Our email delivery partner continues working to resolve the issue.
Posted Feb 12, 2024 - 16:13 PST
Identified
Our email delivery partner is currently experiencing intermittent issues. They are actively working to resolve the issue as quickly as possible.
Posted Feb 12, 2024 - 11:35 PST
This incident affected: Partners (Mailgun).