DrFirst E-prescribing issues
Incident Report for Luminello
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 10:46 PDT
Investigating
We have been notified about issues regarding access to Rcopia and e-prescribing. We've reached out to DrFirst and a solution is currently under development.
Posted Jun 01, 2023 - 09:52 PDT
This incident affected: Partners (DrFirst).